码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2162 Add ‘em

时间:2018-08-05 00:41:35      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:put   lines   content   break   highlight   contains   printf   seve   int   

http://acm.hdu.edu.cn/showproblem.php?pid=2162

 

Problem Description
Write a program to determine the summation of several sets of integers.
 
Input
The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.
 
Output
A single line of output should be generated for each set of integers. The line should have format shown below.
 
Sample Input
4
-1
3
1
1
2
19
17
5
-645
952
-1488
-5456
-9342
-1
 
Sample Output
Sum of #1 is 4
Sum of #2 is 36
Sum of #3 is -15979
 
代码:
#include <bits/stdc++.h>
using namespace std;

int a[1111];

int main() {
    int n, cnt = 0;
    while(~scanf("%d", &n)) {
        getchar();
        if(n <= 0) break;
        cnt ++;
        int sum = 0;
        for(int i = 1; i <= n; i ++) {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        
        printf("Sum of #%d is %d\n", cnt, sum);

    }
    return 0;
}

  

HDU 2162 Add ‘em

标签:put   lines   content   break   highlight   contains   printf   seve   int   

原文地址:https://www.cnblogs.com/zlrrrr/p/9420575.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!