码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1008 Elevator

时间:2018-08-05 17:28:16      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:ecif   time   ESS   led   output   with   max   int   which   

https://pintia.cn/problem-sets/994805342720868352/problems/994805511923286016

 

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

代码:
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int flo[111];

int cmp(int a, int b) {
    if(b > a)
        return 6 * (b - a);
    else if(b < a)
        return 4 * (a - b);
    else return 0;
}

int main() {
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= n; i ++)
        scanf("%d", &flo[i]);

    int time = 0, wait = 0;
    wait = n * 5;
    for(int i = 1; i < n; i ++) {
        time += cmp(flo[i], flo[i + 1]);
    }
    time = time + wait + flo[1] * 6;

    printf("%d\n", time);

    return 0;
}

  

PAT 甲级 1008 Elevator

标签:ecif   time   ESS   led   output   with   max   int   which   

原文地址:https://www.cnblogs.com/zlrrrr/p/9426372.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!