码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1520 Anniversary party

时间:2018-08-05 18:36:21      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:attach   employees   style   cin   pos   should   eva   cal   state   

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.

InputEmployees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0OutputOutput should contain the maximal sum of guests‘ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
本人做的树形dp第一题..
具体的话就是子节点和父节点不能同时选择
转移方程就是:dp[r][1] += dp[j][0] //选择父节点,就不选子节点
dp[r][0] += max(dp[j][0],dp[j][1]) //不选择父节点,看子节点的选择与否,并且挑选中比较大的
#include<bits/stdc++.h>
using namespace std;
const int m = 6000 + 10;
vector<int> g[m];
int fa[m],dp[m][2];
int n;
void dfs(int r)
{
    int len = g[r].size();
    for(int i = 0; i < len; i++)
    {
        int j = g[r][i];
        dfs(j);
        dp[r][1] += dp[j][0];
        dp[r][0] += max(dp[j][1],dp[j][0]);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 1; i <= n; i++)
        {
            dp[i][0] = 0;
            cin>>dp[i][1];
            g[i].clear();
            fa[i] = 0;
        }
        
        int l,k;
        while(scanf("%d%d",&l,&k) && (l+k))
        {
            g[k].push_back(l);
            fa[l] = k;
        }
        int root;
        for(int i = 1; i <= n; i++)
        {
            if(fa[i] == 0)
            {
                root = i;
                break;
            }
        }
        dfs(root);
        cout<<max(dp[root][0],dp[root][1])<<endl;
    }
    return 0;
}

Oooooooo.

HDU 1520 Anniversary party

标签:attach   employees   style   cin   pos   should   eva   cal   state   

原文地址:https://www.cnblogs.com/lwsh123k/p/9426631.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!