码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2132 An easy problem

时间:2018-08-09 21:05:38      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:title   bottom   ica   print   ref   ons   Once   file   ase   

http://acm.hdu.edu.cn/showproblem.php?pid=2132

 

Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 
Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 
Output
  output the result sum(n).
 
Sample Input
1
2
3
-1
 
Sample Output
1
3
30

 代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
long long sum[maxn];

int main() {
    sum[0] = 0;
    for(long long i = 1; i < maxn; i ++) {
        if(i % 3 == 0)
            sum[i] = sum[i - 1] + i * i * i;
        else
            sum[i] = sum[i - 1] + i;
    }
    int x;
    while(~scanf("%d", &x)) {
        if(x < 0)
            break;
        else
            printf("%lld\n", sum[x]);
    }
    return 0;
}

  

HDU 2132 An easy problem

标签:title   bottom   ica   print   ref   ons   Once   file   ase   

原文地址:https://www.cnblogs.com/zlrrrr/p/9451327.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!