码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3104 Drying(二分

时间:2018-08-11 21:59:20      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:weight   cond   txt   smart   mil   miss   res   possible   iat   

Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22163   Accepted: 5611

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1 3 2 3 9 5 sample input #2 3 2 3 6 5

Sample Output

sample output #1 3 sample output #2 
题意:有n件衣服,每件衣服有一个湿度ai,如果把衣服放着,这些衣服每秒钟会自然风干一点适度,如果把衣服放在热机上面每秒钟会热干k-1点湿度值吗,求最少多少秒会风干
题解:二分时间,每次枚举的时间后,将原先的湿度值减少改时间的湿度值,然后将每个大于(k-1)湿度值的放在热机上计算所需要的时间,因为时间是线性单调的,所以就可以使用二分来求
代码如下:
技术分享图片
#include <map>
#include <set>
#include <cmath>
#include <ctime>
#include <stack>
#include <queue>
#include <cstdio>
#include <cctype>
#include <bitset>
#include <string>
#include <vector>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define fuck(x) cout<<"["<<x<<"]";
#define FIN freopen("input.txt","r",stdin);
#define FOUT freopen("output.txt","w+",stdout);
//#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int maxn = 1e5+5;
/*
> 二分枚举时间,判断可行性,然后求解即可.
> 
> 注意判断可行性的过程:
> 
> 1.先把所有衣服的含水量减去T
> 2.然后把>=(k-1)的拿去烘干,
可以理解为烘干时候每分钟掉(k-1)水,
这样所有的衣服都每分钟自然干掉1水了。
因为每分钟掉一滴水是肯定的了,
因此,如果你去烘干它的话,
那么它就能再掉多k-1 + 1 == k,
这样才是k滴水,然后就是计算总花费时间
> 3.最后判断总花费时间时候小于T,
若小于等于,则可行性,否则不可行.
*/
LL a[maxn];
LL b[maxn];
int main(){

    LL n,k;
    int cas=1;
    while(~scanf("%lld",&n)){
        for(int i=0;i<n;i++){
            scanf("%lld",&a[i]);
        }
        LL l=0;
        LL r=1e9;
        scanf("%lld",&k);
        if(k==1){
            LL ans=0;
            for(int i=0;i<n;i++){
                ans=max(ans,a[i]);
            }
            cout<<ans<<endl;

        }else{
            while(l<r){
                LL mid=(l+r)/2;
                for(int i=0;i<n;i++) b[i]=a[i]-mid;
                    LL t=0;
                for(int i=0;i<n;i++){
                    if(b[i]>=(k-1)){
                        if(b[i]%(k-1)==0) t+=b[i]/(k-1);
                        else{
                            t+=b[i]/(k-1) + 1;
                        }
                    }else if(b[i]>0){
                        t++;
                    }
                }
                if(t<=mid) r=mid;
                else l=mid+1;
            }
            cout<<r<<endl;
        }
    }
}   
View Code

 

POJ 3104 Drying(二分

标签:weight   cond   txt   smart   mil   miss   res   possible   iat   

原文地址:https://www.cnblogs.com/buerdepepeqi/p/9460976.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!