码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5058 So easy(STL set运用)

时间:2014-10-05 22:16:29      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:hdu   bc   stl   set   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5058


Problem Description
Small W gets two files. There are n integers in each file. Small W wants to know whether these two files are same. So he invites you to write a program to check whether these two files are same. Small W thinks that two files are same when they have the same integer set.
For example file A contains (5,3,7,7),and file B contains (7,5,3,3). They have the same integer set (3,5,7), so they are same.
Another sample file C contains(2,5,2,5), and file D contains (2,5,2,3).
The integer set of C is (2,5),but the integer set of D is (2,3,5),so they are not same.
Now you are expected to write a program to compare two files with size of n.
 

Input
Multi test cases (about 100). Each case contain three lines. The first line contains one integer n represents the size of file. The second line contains n integers $a_1, a_2, a_3, \ldots, a_n$ - represents the content of the first file. The third line contains n integers $b_1, b_2, b_3, \ldots, b_n$ - represents the content of the second file.
Process to the end of file.
$1 \leq n \leq 100$
$1 \leq a_i , b_i \leq 1000000000$
 

Output
For each case, output "YES" (without quote) if these two files are same, otherwise output "NO" (without quote).
 

Sample Input
3 1 1 2 1 2 2 4 5 3 7 7 7 5 3 3 4 2 5 2 3 2 5 2 5 3 1 2 3 1 2 4
 

Sample Output
YES YES NO NO
 

Source


代码如下:

#include <cstdio>
#include <algorithm>
#include <set>
using namespace std;
int main()
{
    set<int>s1,s2;
    int n;
    while(~scanf("%d",&n))
    {
        s1.clear();
        s2.clear();
        int tt;
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&tt);
            s1.insert(tt);
        }
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&tt);
            s2.insert(tt);
        }
        if(s1.size() != s2.size())
        {
            printf("NO\n");
            continue;
        }
        int flag = 0;
        set<int>::iterator it1, it2;
        for(it1 = s1.begin(),it2 = s2.begin(); it1!=s1.end()&&it2!=s2.end(); it1++,it2++)
        {
            if(*it1 != *it2)
            {
                flag = 1;
                break;
            }
        }
        if(flag)
        {
            printf("NO\n");
        }
        else
            printf("YES\n");
    }
    return 0;
}


HDU 5058 So easy(STL set运用)

标签:hdu   bc   stl   set   

原文地址:http://blog.csdn.net/u012860063/article/details/39807119

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!