码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2451 Simple Addition Expression(组合数学)

时间:2014-10-06 00:13:59      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   组合   排列   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2451


Problem Description
A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves.

The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too.

The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer‘s adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea.

The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following:

A former mathematician defined a kind of simple addition expression. 
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression.

For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry.

However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding.

when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression.

when the value of n is large enough, the problem needs to be solved by means of computer.

 
Input
There are several test cases, each case takes up a line, there is an integer n (n<10^10).

 
Output
Output the number of all simple addition expressions when i<n.

 
Sample Input
1 2 3 4 10 11
 
Sample Output
1 2 3 3 3 4
 
Source
 

题意:

对于小于 n 的整数 i 中(i + i+1 + i+2)不会产生进位的一共有多少种。


PS:

最高位满足1,2,3;中间的数要满足0,1,2,3;个位数满足0,1,2;

所以只要找出小于 n 的数满足这个条件的个数;



代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
typedef __int64 LL;
int main()
{
    char s[17];
    while(~scanf("%s",s))
    {
        LL ans = 0;
        int len = strlen(s);
        int flag = 0;
        for(int i = 0; i < len-1; i++)
        {
            if(s[i] > '3')
            {
                ans += pow(4.0,len-i-1)*3;
                flag = 1;
                break;
            }
            ans += (s[i]-'0')*pow(4.0,len-i-2)*3;
        }
        if(!flag)
        {
            if(s[len-1] > '3')
                ans += 3;
            else
                ans += s[len-1]-'0';
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


HDU 2451 Simple Addition Expression(组合数学)

标签:hdu   数学   组合   排列   

原文地址:http://blog.csdn.net/u012860063/article/details/39806867

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!