码迷,mamicode.com
首页 > 其他好文 > 详细

EXTENDED LIGHTS OUT (高斯消元)

时间:2018-08-16 23:50:20      阅读:290      评论:0      收藏:0      [点我收藏+]

标签:size   containe   nss   atp   center   +=   off   nbsp   lines   

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.
技术分享图片

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.
技术分享图片

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.
Input
The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output
For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1‘s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input
2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0
Sample Output
PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

大佬博客 : https://blog.csdn.net/FromATP/article/details/53966305

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long lint;
const double PI = acos(-1.0);
const int INF = 1000000000;
const int maxn = 100005;

// 暴力枚举 :
/*
int mp[20][20], cal[20][20], vis[20][20];
int n, m;
int dr[5][2] = { {0,1}, {0,-1}, {1,0}, {-1,0}, {0,0} };
int mi = INF;

int fz(int x, int y)
{
    int t = mp[x][y];
    for(int i = 0; i< 5; i++)
    {
        int xx = x + dr[i][0];
        int  yy = y + dr[i][1];
        if(xx <= n && xx > 0 && yy <= m && yy >0)
            t += vis[xx][yy];
    }
    return t%2;
}

int dfs()
{

        for(int j = 2; j <= n; j++)
            for(int k = 1; k <= m; k++)
        {
            if(fz(j-1, k))  vis[j][k] = 1;
        }
        for(int j = 1; j <= m; j++)
        {
            if(fz(n, j))
            return -1;
        }
        int cnt = 0;
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= m; j++)
                cnt += vis[i][j];
    return cnt;

}

int main()
{
    ios::sync_with_stdio(false);
    int T;
    cin >> T;
    int ans = 0;
    while(ans++ < T)
    {
        mi = INF;
        n = 5;
        m = 6;
        for(int i = 1; i <=n; i++)
            for(int j = 1; j <=m ; j++)
                cin >> mp[i][j];
        int flag = 0;
        for(int i = 0; i < 1<<m ; i++)
        {
            memset(vis, 0, sizeof(vis));
            for(int j = 1; j <= m; j++)
                vis[1][m-j+1] = i>>(j-1) & 1;


            int cnt  = dfs();
            if(cnt < mi && cnt >= 0)
            {
                flag =1;
                mi = cnt;
                memcpy(cal, vis, sizeof(vis));
            }

        }
        cout << "PUZZLE #" << ans << endl;
        if(flag)
        {
            for(int i = 1; i <=n; i++)
            {
                for(int j = 1; j <= m; j++)
                {
                    if(j != 1) cout << " ";
                     cout << cal[i][j];
                }

                cout << endl;
            }
        }

        else cout << "IMPOSSIBLE" << endl;
        }

    return 0;
}
*/
// 高斯消元法 :

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int n=30;
int tt,a[n+10][n+10];
void gauss()//保证有解
{
    int r;
    for(int i=1;i<=n;i++)
     {
         for(int j=i;j<=n;j++)if(a[j][i]){r=j;break;}
         if(r!=i)for(int j=1;j<=n+1;j++) swap(a[i][j],a[r][j]);
         for(int j=i+1;j<=n;j++)if(a[j][i])
          for(int k=i;k<=n+1;k++)
           a[j][k]^=a[i][k];
     }
    for(int i=n;i>=1;i--)
     for(int j=i+1;j<=n;j++)
      if(a[i][j])a[i][n+1]^=a[j][n+1];
}
int main()
{
    scanf("%d",&tt);
    int t=0;
    while(tt--)
     {
         t++;
         memset(a,0,sizeof(a));
         for(int i=1;i<=n;i++)
         {
             scanf("%d",&a[i][n+1]);
             a[i][i]=1;
             if(i%6!=1)a[i][i-1]=1;
             if(i%6!=0)a[i][i+1]=1;
             if(i>6)a[i][i-6]=1;
             if(i<25)a[i][i+6]=1;
         }
        gauss();
        printf("PUZZLE #%d\n",t);
        for(int i=1;i<=n;i++)
         {
             if(!(i%6))printf("%d\n",a[i][n+1]);
             else printf("%d ",a[i][n+1]);
         }
     }
    return 0;
}

 



EXTENDED LIGHTS OUT (高斯消元)

标签:size   containe   nss   atp   center   +=   off   nbsp   lines   

原文地址:https://www.cnblogs.com/mrh-acmer/p/9490671.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!