码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1112 Stucked Keyboard

时间:2018-08-19 18:26:26      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:inpu   ever   map   main   ret   ace   eating   list   possible   

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:
ei
case1__this_isss_a_teest

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
  int times, t=0;
  string s;
  cin>>times>>s;
  char c=s[0];
  map<char, int> bkey;
  vector<char> ans;
  for(int i=0; i<s.size(); i++){
    if(s[i]==c){
      t++;
    }else{
      if(t%times==0&&bkey[c]==0){
         ans.push_back(c);
         bkey[c]=2;
      }
      else if(t%times!=0){
         if(bkey[c]==2)
            ans.erase(find(ans.begin(), ans.end(), c));
         bkey[c]=1;
      }
      c=s[i];
      t=1;
    }
  }
  if(t%times==0&&bkey[c]==0){
    ans.push_back(c);
    bkey[c]=2;
  }
  for(int i=0; i<ans.size(); i++)
    cout<<ans[i];
  cout<<endl;
  for(int i=0; i<s.size(); i++){
    cout<<s[i];
    if(bkey[s[i]]==2)
        i+=times-1;
  }
  return 0;
}

PAT 1112 Stucked Keyboard

标签:inpu   ever   map   main   ret   ace   eating   list   possible   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501992.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!