码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1120 Friend Numbers

时间:2018-08-19 19:03:09      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:input   output   tput   contains   main   sample   auto   different   str   

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID‘s among them.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10^4 .

Output Specification:
For each case, print in the first line the number of different frind ID‘s among the given integers. Then in the second line, output the friend ID‘s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:
8
123 899 51 998 27 33 36 12

Sample Output:
4
3 6 9 26

#include<iostream> //水题
#include<set>
using namespace std;
int main(){
  int n;
  cin>>n;
  set<int> ans;
  for(int i=0; i<n; i++){
    string s;
    cin>>s;
    int sum=0;
    for(int j=0; j<s.size(); j++)
      sum+=s[j]-'0';
    ans.insert(sum);
  }
  cout<<ans.size()<<endl;
  cout<<*ans.begin();
  for(auto it=++ans.begin(); it!=ans.end(); it++)
    cout<<" "<<*it;
  cout<<endl;
  return 0;
}

PAT 1120 Friend Numbers

标签:input   output   tput   contains   main   sample   auto   different   str   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502078.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!