码迷,mamicode.com
首页 > 其他好文 > 详细

poj1979 Red and Black

时间:2018-08-21 16:04:03      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:rom   cep   and   sts   ted   string   stdio.h   main   data   

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 43713   Accepted: 23706

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

//poj1979
#include<stdio.h> 
#include<iostream>
#include <string.h>
int chess[22][22];
int dir[4][2] = {{0,-1},{1,0},{0,1},{-1,0} };
int status;  //方案计数器  
int n, k, x, y;
void DFS(int x, int y)    
{
    chess[x][y] = 1;//走过的点就标记
    status++;
    for (int j = 0; j < 4; j++)
    {
        int xx = x + dir[j][1];
        int yy = y + dir[j][0];
        if (xx < k && xx >= 0 && yy >= 0 && yy < n && chess[xx][yy] == 0)
            DFS(xx, yy);
    }
    return ;
}
int main()
{
    while (scanf("%d%d", &n, &k) != EOF)
    {
        getchar();
        if (n == 0 && k == 0)
            break;
        memset(chess, 0, sizeof(chess));//对数组清零操作
        status = 0;
        for (int i = 0; i<k; i++)
        {
            for (int j = 0; j<n; j++)
            {
                char temp;
                scanf("%c", &temp);
                if (temp == #)
                {
                    chess[i][j] = 1;
                }
                if (temp == @)
                {
                    x = i;
                    y = j;
                }
            }
            getchar();
        }
        
        DFS(x, y);  //注意初始化的值别弄错了  
        printf("%d\n", status);
    }
    return 0;
}

 

poj1979 Red and Black

标签:rom   cep   and   sts   ted   string   stdio.h   main   data   

原文地址:https://www.cnblogs.com/-citywall123/p/9511692.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!