码迷,mamicode.com
首页 > 其他好文 > 详细

92-珠子染色-置换群

时间:2018-08-24 23:40:40      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:sea   form   define   field   NPU   ret   The   lse   翻转   

                                       Necklace of Beads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9655   Accepted: 3968

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 
技术分享图片

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

 
技术分享图片
#include <iostream>
#include <algorithm>
#include <cmath> 
using namespace std;
#define LL long long

LL gcd(LL a, LL b){
	return b == 0 ? a : gcd(b, a % b);
}

int main(){
	LL n, sum = 0;
	while(cin >> n && n != -1){
		if(n == 0){
			cout << 0 << endl;
			continue;
		}
		//旋转变换 
		//n种置换,步长为x的置换的循环节有GCD(x,n)个
		for(int i = 1; i <= n; i++){
			sum += pow(3, gcd(i, n));
		}
		//翻转变换:要分奇偶
		if(n & 1){
			sum += n * pow(3, (n - 1) / 2 + 1);
		} 
		else{
			sum += n/2 * pow(3, (n - 2) / 2 + 2); //按两个点翻转 
			sum += n/2 * pow(3, n / 2); //按边翻转   
		}
		sum /= 2 * n;  //除以G:总的置换个数 
		cout << sum << endl; 
		sum = 0; 
	}
}

  

 

92-珠子染色-置换群

标签:sea   form   define   field   NPU   ret   The   lse   翻转   

原文地址:https://www.cnblogs.com/zhumengdexiaobai/p/9532316.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!