码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 2421(最小生成树.prim)

时间:2018-08-26 10:31:10      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:from   ble   矩阵   c代码   std   esc   space   代码   job   

题目:

题目链接:

http://poj.org/problem?id=2421

Constructing Roads

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27947 Accepted: 12316

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题目思路 :

只要把邻接矩阵 已经建好的路径改成0  然后就用模板就好了

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int road[1005][1005],vis[1005],dis[1005];
const int inf = 0x3f3f3f3f;
 
int main()
{
//    freopen("in.txt","r",stdin);
    int n,sum,minroad,fre,j,i,q,a,b;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            scanf("%d",&road[i][j]);
        scanf("%d",&q);
        for(int i=1;i<=q;i++)//把已经建好的路径修改为0
        {
            scanf("%d %d",&a,&b);
            road[a][b]=0;
            road[b][a]=0;
        }
 
        for(i=1;i<=n;i++)
            dis[i]=road[1][i];
        memset(vis,0,sizeof(vis));
 
        vis[1]=1;
        sum=0;
        fre=1;
        while(fre < n)
        {
            minroad = inf;
            for(j=0,i=1;i<=n;i++)
            {
                if(vis[i]==0 && dis[i]<minroad)
                {
                    minroad = dis[i];
                    j=i;
                }
            }
            sum += minroad;
            fre++;
            vis[j]=1;
            for(i=1;i<=n;i++)
                if(vis[i]==0 && road[j][i]<dis[i])
                    dis[i] = road[j][i];
        }
        printf("%d\n",sum);
    }
 
}

 

POJ - 2421(最小生成树.prim)

标签:from   ble   矩阵   c代码   std   esc   space   代码   job   

原文地址:https://www.cnblogs.com/20172674xi/p/9536193.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!