码迷,mamicode.com
首页 > 其他好文 > 详细

Find Integer

时间:2018-08-26 11:52:37      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:return   contest   ram   amp   people   atom   int   scan   frame   

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6597    Accepted Submission(s): 1852
Special Judge


Problem Description
people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.
 

 

Input
one line contains one integer T;(1T1000000)

next T lines contains two integers n,a;(0n1000,000,000,3a40000)
 

 

Output
print two integers b,c if b,c exits;(1b,c1000,000,000);

else print two integers -1 -1 instead.
 

 

Sample Input
1 2 3
 

 

Sample Output
4 5

 定理:

费马大定理

a^n+b^n = c^n 若n大于2则无正整数解

只需要特判下0,1 然后找下2的解就可以

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;

int main()
{
    int t,n,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&a);
        if(n==0)
        {
            printf("-1 -1\n");
        }
        if(n==1)
        {
            printf("1 %d\n",a+1);
        }
        if(n==2)
        {
            if(a%2==0)
            {
                printf("%d %d\n",(a*a/2-2)/2,(a*a/2+2)/2);
            }
            else
            {
                printf("%d %d\n",(a*a-1)/2,(a*a+1)/2);
            }
        }
        if(n>=3)
        {
            printf("-1 -1\n");
        }
    }
    return 0;
}

 

Find Integer

标签:return   contest   ram   amp   people   atom   int   scan   frame   

原文地址:https://www.cnblogs.com/hao-tian/p/9536405.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!