码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3455 Leap Frog(状压DP)

时间:2014-10-07 13:34:33      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   sp   

Problem Description
Jack and Jill play a game called "Leap Frog" in which they alternate turns jumping over each other. Both Jack and Jill can jump a maximum horizontal distance of 10 units in any single jump. You are given a list of valid positions x1,x2,…, xn where Jack or Jill may stand. Jill initially starts at position x1, Jack initially starts at position x2, and their goal is to reach position xn.Determine the minimum number of jumps needed until either Jack or Jill reaches the goal. The two players are never allowed to stand at the same position at the same time, and for each jump, the player in the rear must hop over the player in the front.
 

Input
The input file will contain multiple test cases. Each test case will begin with a single line containing a single integer n (where 2 <= n <= 100000). The next line will contain a list of integers x1,x2,…, xn where 0 <=x1,x2,…, xn<= 1000000. The end-of-fi le is denoted by a single line containing "0".
 

Output
For each input test case, print the minimum total number of jumps needed for both players such that either Jack or Jill reaches the destination, or -1 if neither can reach the destination.
 

Sample Input
6 3 5 9 12 15 17 6 3 5 9 12 30 40
 

Sample Output
3 -1
 

Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
const int INF=0x3f3f3f;
const int maxn=1e5+100;
int dp[maxn][15];
int hash[10*maxn];
int num[maxn],n;
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(dp,INF,sizeof(dp));
        memset(hash,-1,sizeof(hash));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            hash[num[i]]=i;
        }
        dp[2][num[2]-num[1]]=0;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=10;j++)
            {
                if(j>num[i])  break;
                for(int k=j+1;k<=10;k++)
                {
                    int tt=num[i]-j;
                    if(hash[tt]>=0)
                        dp[i][j]=min(dp[hash[tt]][k-j]+1,dp[i][j]);
                }
            }
        }
        int ans=INF;
        for(int i=1;i<=10;i++)
//        {
//            cout<<"1111   "<<dp[n][i]<<endl;
            ans=min(ans,dp[n][i]);
//        }
        if(ans<INF) printf("%d\n",ans);
        else   printf("-1\n");
    }
    return 0;
}

hdu 3455 Leap Frog(状压DP)

标签:des   style   http   color   io   os   ar   for   sp   

原文地址:http://blog.csdn.net/u013582254/article/details/39852935

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!