码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1089 Intervals【合并n个区间/贪心】

时间:2018-08-31 14:09:07      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:str   def   rate   tput   max   task   may   contain   inter   

There is given the series of n closed intervals [ai; bi], where i=1,2,...,n. The sum of those intervals may be represented as a sum of closed pairwise non−intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order. We say that the intervals [a; b] and [c; d] are in ascending order if, and only if a <= b < c <= d. 
Task 
Write a program which: 
reads from the std input the description of the series of intervals, 
computes pairwise non−intersecting intervals satisfying the conditions given above,
writes the computed intervals in ascending order into std output

Input

In the first line of input there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)−st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval,1 <= ai <= bi <= 1000000.

Output

The output should contain descriptions of all computed pairwise non−intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output in ascending order.

Sample Input

5
5 6
1 4
10 10
6 9
8 10

Sample Output

1 4
5 10

 

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
#include <list>
#include <deque>
#include <map>
#include <set>
using namespace std;
#define ll long long
const double PI = acos(-1.0);
const int maxn = 101;
const int INF = 0x3f3f3f3f;
int dx[]={0,0,-1,1};
int dy[]={-1,1,0,0};

int n,m;
int f[maxn],cnt=0,sum=0;
struct node
{
    int l,r;
}a[maxn];
bool cmp(node a,node b)
{
    return a.l<b.l;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d %d",&a[i].l,&a[i].r);
        sort(a,a+n,cmp);
        int x=a[0].l,y=a[0].r;
        for(int i=0;i<n;i++)
        {
            if(a[i].l>=x && a[i].l<=y)
            {
                if(a[i].r>y)
                    y=a[i].r;
            }
            else
            {
                printf("%d %d\n",x,y);
                x=a[i].l;
                y=a[i].r;
            }
        }
        printf("%d %d\n",x,y);
    }
}
/*

*/

 

POJ 1089 Intervals【合并n个区间/贪心】

标签:str   def   rate   tput   max   task   may   contain   inter   

原文地址:https://www.cnblogs.com/Roni-i/p/9565229.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!