码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1143 Lowest Common Ancestor[难][BST性质]

时间:2018-08-31 22:22:35      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:pes   span   inpu   关键字   ext   sequence   ios   二叉搜索树   fat   

1143 Lowest Common Ancestor(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if Ais one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 题目大意:给出一棵二叉搜索树的前序遍历,并且给出两个节点,查询这两个节点的最近的共同祖先,如果其中一个是另一个的父节点,那么按格式输出,如果查不到该节点,那么根据相应的格式进行输出。即最小公共祖先。

 //既然关键字的范围是int,那么就不能使用哈西father数组的形式来查找了。

//本来想用map,但是又考虑到会有重复的数,所以就不能用了。

技术分享图片View Code

 

 //实在是不太会,就写了这么点,就是不知道怎么去给这些node标记父节点。

//看到柳神说这是水题,我的内心接受不了了。。

代码来自:https://www.liuchuo.net/archives/4616

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
    int m, n, u, v, a;
    scanf("%d %d", &m, &n);
    vector<int> pre(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;//表示这个节点出现了
    }
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &u, &v);
        for(int j = 0; j < n; j++) {
            a = pre[j];//其实每一个节点都是根节点。
            if ((a >= u && a <= v) || (a >= v && a <= u)) break;
            //如果a在两者之间或者就是当前节点其中一个,
        }
        if (mp[u] == false && mp[v] == false)//false就是都没有出现,也就是0。
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if (mp[u] == false || mp[v] == false)
            printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
        else if (a == u || a == v)
            printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
        else
            printf("LCA of %d and %d is %d.\n", u, v, a);
    }
    return 0;
}

 

1.有一个规律,输入是按照前根遍历来输入的,那么每一个数的前一个数,就是当前数的根节点啊!哪里用建树呢?!

2.利用了搜索二叉树的性质,真是厉害,学习了。

3.判断a是在u和v之间,还是恰好是u和v.

PAT 1143 Lowest Common Ancestor[难][BST性质]

标签:pes   span   inpu   关键字   ext   sequence   ios   二叉搜索树   fat   

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9568455.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!