码迷,mamicode.com
首页 > 其他好文 > 详细

【2018ICPC南京网络赛 A】An Olympian Math Problem(数论题)

时间:2018-09-02 01:53:37      阅读:444      评论:0      收藏:0      [点我收藏+]

标签:stream   ase   color   top   南京   minus   padding   cas   ott   

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! = 1 × 2 × ? × (k - 1) × k

We denote S:

S = 1 × 1! + 2 × 2! + ? + (n1)×(n1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that ≤ ≤ 1018.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: × 11, and 1 modulo 2 is 1.

The second test is: × 1× 25 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2

题意:

已知S = 1 × 1! + 2 × 2! + ? + (n1)×(n1)!,求S%n的值。

思路:

直接给结论吧,S%n=n-1

#include<iostream> 
using namespace std;
typedef long long ll;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        ll n;
        cin>>n;
        cout<<n-1<<endl;
    }
    return 0;
}

 

【2018ICPC南京网络赛 A】An Olympian Math Problem(数论题)

标签:stream   ase   color   top   南京   minus   padding   cas   ott   

原文地址:https://www.cnblogs.com/kannyi/p/9572101.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!