码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 17 单调递增最长子序列

时间:2014-10-08 00:16:54      阅读:291      评论:0      收藏:0      [点我收藏+]

标签:style   color   io   os   ar   for   sp   div   c   

单调递增最长子序列

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述
求一个字符串的最长递增子序列的长度
如:dabdbf最长递增子序列就是abdf,长度为4
输入
第一行一个整数0<n<20,表示有n个字符串要处理
随后的n行,每行有一个字符串,该字符串的长度不会超过10000
输出
输出字符串的最长递增子序列的长度
样例输入
3
aaa
ababc
abklmncdefg
样例输出
1
3
7
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b;
char str[10005];
int  s[10005];
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
	   int i,j,ans=0,len;
	   scanf("%s",str);
	   len=strlen(str);//计算字符串的长度
      for(i=0;i<len;i++)//循环计算累加
	  {
		  s[i]=1;
		  for(j=0;j<i;j++)
		  {
			  if(str[i]>str[j])
			     s[i]=max(s[i],s[j]+1);
		  }
		  ans=max(s[i],ans);//找出最长的
	  }
	  printf("%d\n",ans);
	}
	return 0;
}



nyoj 17 单调递增最长子序列

标签:style   color   io   os   ar   for   sp   div   c   

原文地址:http://blog.csdn.net/u013238646/article/details/39860191

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!