码迷,mamicode.com
首页 > 其他好文 > 详细

浙大pat1039 Course List for Student(25 分)

时间:2018-09-03 22:28:23      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:ios   题解   reg   who   测试   wing   ble   nts   ack   

1039 Course List for Student(25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (40,000), the number of students who look for their course lists, and K (2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (200) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
作者: CHEN, Yue
单位: 浙江大学
时间限制: 600 ms
内存限制: 64 MB
代码长度限制: 16 KB

 题解:这道题就是考差哈希存储 如果暴力肯定过不了,我用的c++自带的map,最后一个测试点过不了,看了网上的大佬基本都用了哈希算法,我当时怕哈希冲突就没用这个,但是网上看到还是可以设计好的哈希函数来避免冲突的

比如这个:

int getID(string name){
    int id = 0;
    for(int i=0; i<3; i++){
        id = id*26+(name[i]-‘A‘);
    }
    id = id * 10 + (name[3] - ‘0‘);
    return id;
}

  当时主要是怕序列问题 比如ABC3 和BCA3的哈希很可能一样,但其实简单点的操作一下就行了。学会这种哈希算法。

(来源:https://blog.csdn.net/Q_smell/article/details/82284795)

 

下面贴一下我的没用哈希的map代码,虽然最后一个测试点没过,但是这种写法让我熟悉了map的操作(包括值为vector)有一定的借鉴意义。

#include <iostream>
#include <map>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
int main(int argc, char *argv[]) 
{
	vector<string>query;
	map<string,vector<int> > hash;
	int n,k;
	cin>>n>>k;
	for(int i=0;i<k;i++)
	{
		int n1,k1;
		cin>>n1>>k1;
		for(int j=0;j<k1;j++)
		{
			string s;
			cin>>s;
			hash[string(s)].push_back(n1);
		}
	}
	for(int i = 0;i<n;i++)
	{
		string tmp;
		cin>>tmp;
		
		query.push_back(tmp);
	}
	for(int  i=0;i<n;i++)
	{
		int num = hash[query[i]].size();
		sort(hash[query[i]].begin(),hash[query[i]].end());
		cout<<query[i]<<" "<<num;
		for(int j=0;j<num;j++)
		{
			cout<<" "<<hash[query[i]][j];
		}
		cout<<endl;
	}
}

  

浙大pat1039 Course List for Student(25 分)

标签:ios   题解   reg   who   测试   wing   ble   nts   ack   

原文地址:https://www.cnblogs.com/SK1997/p/9581462.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!