码迷,mamicode.com
首页 > 其他好文 > 详细

Zero Sum 和为零(深搜)

时间:2018-09-06 21:30:50      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:oid   留空   应该   nbsp   没有   表达式   ascii   put   esc   

Description

请考虑一个由1到N(N=3, 4, 5 ... 9)的数字组成的递增数列:1 2 3 ... N。 现在请在数列中插入“+”表示加,或者“-”表示减,抑或是“ ”表示空白,来将每一对数字组合在一起(请不在第一个数字前插入符号)。 计算该表达式的结果并注意你是否得到了和为零。 请你写一个程序找出所有产生和为零的长度为N的数列。

Input

单独的一行表示整数N (3 <= N <= 9)。

Output

按照ASCII码的顺序,输出所有在每对数字间插入“+”, “-”, 或 “ ”后能得到和为零的数列。(注意:就算两个数字之间没有插入符号也应该保留空格)

Sample Input

7

Sample Output

1+2-3+4-5-6+7
1+2-3-4+5+6-7
1-2 3+4+5+6+7
1-2 3-4 5+6 7
1-2+3+4-5+6-7
1-2-3-4-5+6+7


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[20];
int n;
void DFS(int pos,int sum,int last)///三个参数:当前位置,不含当前位置的和,当前位置上的数
{
    int i;
    if(pos==n)
    {
        if(sum+last==0)
        {
            printf("%s\n",s);
        }
        return;
    }
    s[pos*2-1]= ;  //搜索‘ ’号
    if(last>0)
    {
        DFS(pos+1,sum,last*10+pos+1);
    }
    else
    {
        DFS(pos+1,sum,last*10-pos-1);
    }
    s[pos*2-1]=+;  //搜索‘+’号
    DFS(pos+1,sum+last,pos+1);
    s[pos*2-1]=-;  //搜索‘-’号
    DFS(pos+1,sum+last,-(pos+1));
}

int main()
{
    int i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        s[i*2]=i+1;
    }
    DFS(1,0,1);
    return 0;
}

 

Zero Sum 和为零(深搜)

标签:oid   留空   应该   nbsp   没有   表达式   ascii   put   esc   

原文地址:https://www.cnblogs.com/wkfvawl/p/9600979.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!