码迷,mamicode.com
首页 > 其他好文 > 详细

Common Subsequence

时间:2018-09-09 00:37:47      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:nta   ram   one   dex   sam   common   abc   ble   nts   

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int M[10001][10001];
int main()
{
    int n, m, j, k, i;
    string a, b;
    while (cin >> a >> b)
    {
        n = a.length();
        m = b.length();
        for (i = 0; i <= n; i++)
            M[i][0] = 0;
        for (j = 0; j <= m; j++)
            M[0][j] = 0;
        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= m; j++)
            {
                if (a[i - 1] == b[j - 1])
                {
                    M[i][j] = M[i - 1][j - 1] + 1;
                }
                else {
                    M[i][j] = max(M[i][j - 1], M[i - 1][j]);
                }
            }
        }
        cout << M[n][m] << endl;
    }
}

 

Common Subsequence

标签:nta   ram   one   dex   sam   common   abc   ble   nts   

原文地址:https://www.cnblogs.com/baobao2201128470/p/9610982.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!