码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1005 Number Sequence(数论)

时间:2018-09-12 14:02:43      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:sam   数论   clu   sed   his   process   put   break   using   

HDU 1005 Number Sequence(数论)

Problem Description:
A number sequence is defined as follows:f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 1
0 0 0
 
Sample Output
2
5
 
解题思路:因为本题的n非常大,所以通过循环直接求解是不可行的,之后我可能会想到存在某种规律,刚开始以为是每6个就循环一次,很傻,其实是在最开始的时候f(1)和f(2)都为1,那么计算到f(n)时,如果f(n)和f(n-1)的值都为1,又会和最开始一样计算下去,一直循环,n-2个为一个周期。
 

代码:

#include<iostream>
using namespace std;
const int INF = 10000;
int ans[INF];
int main() {
    int A, B, n;
    while(cin >> A >> B >> n) {
        if(!A && !B && !n) break;
        ans[1] = ans[2] = 1;
        ans[3] = (A + B) % 7;
        int t;
        for(int i = 4; i < INF; i++) {
            ans[i] = (A * ans[i-1] + B * ans[i-2]) % 7;
            if(ans[i-1] == 1 && ans[i] == 1) {
                t = i-2;
                break;
            }
        }
        int index = n%t ? n%t : t;
        cout << ans[index] << endl;
    }
    return 0;
}

 

HDU 1005 Number Sequence(数论)

标签:sam   数论   clu   sed   his   process   put   break   using   

原文地址:https://www.cnblogs.com/kindleheart/p/9634214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!