码迷,mamicode.com
首页 > 其他好文 > 详细

2018 徐州网络赛 I

时间:2018-09-13 01:10:37      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:sam   button   网络赛   cte   abs   enc   nan   output   first   

  •  262144K
 

Mur loves hash algorithm, and he sometimes encrypt another one‘s name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256256 , which can transit a string into just 256256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string ss, s[i]s[i] represents the iith character in the string) we calculates the value(|(int) L - s[i]|(int)Ls[i]∣), and write down the number(keeping leading zero. The length of each answer equals to 22because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(ss)). For instance, if we choose ‘z‘ as the seed, the string "oMl" becomes "1114541414".

It‘s easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer TT , the number of test cases (T \le 10)(T10).

For each test case:

First line contains a integer NN and a character zz, (N \le 1000000)(N1000000).

Second line contains a string with length NN . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入

2
3 z
oMl
6 Y
YJSNPI

样例输出

6
10

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

 

思路:

水题。

技术分享图片
#include <bits/stdc++.h>
using namespace std;
char s[1000010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        char a;
        scanf("%d %c",&n,&a);
        scanf("%s",s);
        int l=strlen(s);
        bool ok=false;
        int ans=0;
        for(int i=0; i<l;++i)
        {
            int d=abs(a-s[i]);
            if (ok) ans+=2;
            else {
                if (d>10) {
                    ans+=2;
                    ok=true;
                } else if (d!=0) {
                    ans++;
                    ok=true;
                }
            }
        }
        printf("%d\n",max(ans,1));
    }

    return 0;
}
View Code

 

2018 徐州网络赛 I

标签:sam   button   网络赛   cte   abs   enc   nan   output   first   

原文地址:https://www.cnblogs.com/acerkoo/p/9638101.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!