码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1140 Look-and-say Sequence

时间:2018-09-15 22:03:28      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:cal   pos   pre   esc   char   case   specific   print   cas   

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1‘s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

#include<iostream> //水题
using namespace std;
int main(){
    string d;
    int n;
    cin>>d>>n;
    for(int i=1; i<n; i++){
        char c=d[0];
        string t;
        int cnt=0;
        for(int j=0; j<d.size(); j++){
            if(d[j]==c) cnt++;
            else{
                t.append(1, c);
                t.append(1, cnt+'0');
                cnt=1;
                c=d[j]; 
            }
        }
        t.append(1, c);
        t.append(1, cnt+'0');
        d=t;
    }
    cout<<d<<endl;
    return 0;
} 

PAT 1140 Look-and-say Sequence

标签:cal   pos   pre   esc   char   case   specific   print   cas   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652250.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!