码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1147 Heaps

时间:2018-09-15 22:06:07      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:sci   test   href   ase   begin   sep   g++   end   cas   

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree‘s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

#include<iostream> //水题
#include<vector>
using namespace std;
vector<int> v;
int m, n, flag=0;
void postorder(int r){
    if(r*2+1<n)
        postorder(r*2+1);
    if(2*r+2<n)
        postorder(2*r+2);
    flag++==0?cout<<v[r]:cout<<" "<<v[r];
}
int main(){
    cin>>m>>n;
    v.resize(n);
    for(int i=0; i<m; i++){
        int type=-1;
        flag=0;
        for(int j=0; j<n; j++)
            cin>>v[j];
        if(v[0]>v[1]) type=1;
        for(int i=0; i<=(n-1)/2; i++)
            if(type==1&&(v[i*2+1]>v[i]||(i*2+2<n&&v[i*2+2]>v[i]))){
                type=0;
                break;
            }else if(type==-1&&(v[i*2+1]<v[i]||(i*2+2<n&&v[i*2+2]<v[i]))){
                type=0;
                break;
            } 
        if(type==1) cout<<"Max Heap"<<endl;
        else if(type==-1) cout<<"Min Heap"<<endl;
        else cout<<"Not Heap"<<endl;
        postorder(0);
        cout<<endl;
    }
}

PAT 1147 Heaps

标签:sci   test   href   ase   begin   sep   g++   end   cas   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652316.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!