码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1144 The Missing Number

时间:2018-09-15 22:07:00      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:contain   line   rate   ext   case   turn   sep   rom   positive   

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^5). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:
Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main(){
  int n, t, cnt=1;
  cin>>n;
  set<int> s;
  for(int i=0; i<n; i++){
    cin>>t;
    if(t>0)
      s.insert(t);
  }
  auto it=s.begin();
  for(; it!=s.end(); it++){
    if(cnt++!=*it)
      break;
  }
  it==s.end()?cout<<cnt<<endl:cout<<cnt-1<<endl;
  return 0;
}

PAT 1144 The Missing Number

标签:contain   line   rate   ext   case   turn   sep   rom   positive   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652290.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!