码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1007 Maximum Subsequence Sum

时间:2018-09-16 16:04:08      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:who   def   tst   main   blank   -o   bottom   file   together   

https://pintia.cn/problem-sets/994805342720868352/problems/994805514284679168

 

Given a sequence of K integers { N?1??, N?2??, ..., N?K?? }. A continuous subsequence is defined to be { N?i??, N?i+1??, ..., N?j?? } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

时间复杂度:$O(n)$

代码:

#include <bits/stdc++.h>
using namespace std;

int a[11111];
int dp[11111];

int main() {
    int n;
    scanf("%d", &n);
    int ans = 0, temp = 0, cnt = 0, sum = 0;
    for(int i = 1; i <= n; i ++)
        scanf("%d", &a[i]);
    for(int i = 1; i <= n; i ++) {
        if(a[i] < 0)
            sum ++;
    }
    if(sum == n)
        printf("0 %d %d\n", a[1], a[n]);
    else {
        if(n == 1)
            printf("%d %d %d\n", a[n], a[n], a[n]);
        else {
            for(int i = 0; i < n; i ++) {
                dp[i + 1] = max(a[i + 1], a[i + 1] + dp[i]);
                if(dp[i + 1] > ans) {
                    temp = i + 1;
                    ans = dp[i + 1];
                }
            }
            for(int i = temp; i >= 1 && dp[i] >= 0; i --) 
                cnt = i;
            printf("%d %d %d\n", ans, a[cnt], a[temp]);
        }
    }
    return 0;
}

  

PAT 甲级 1007 Maximum Subsequence Sum

标签:who   def   tst   main   blank   -o   bottom   file   together   

原文地址:https://www.cnblogs.com/zlrrrr/p/9655144.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!