码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-ICPC2018北京网络赛 Saving Tang Monk II(bfs+优先队列)

时间:2018-09-22 21:27:09      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:c++   oom   names   imp   cost   com   ons   saving   nod   

题目1 : Saving Tang Monk II

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng‘en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

‘S‘ : The original position of Sun Wukong

‘T‘ : The location of Tang Monk

‘.‘ : An empty room

‘#‘ : A deadly gas room.

‘B‘ : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a ‘B‘ room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

‘P‘ : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a ‘P‘ room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn‘t get into a ‘#‘ room(deadly gas room) without an oxygen bottle. Entering a ‘#‘ room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a ‘#‘ room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it‘s impossible for Sun Wukong to complete the mission, print -1

样例输入
2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0
样例输出
-1
8
11





#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int n,m;
char s[101][101];
int b[101][101][10];
int t[4][2]={1,0,0,1,-1,0,0,-1};
struct Node{
    int x,y,B,s;
    friend bool operator<(Node a,Node b)
    {
        return a.s>b.s;
    }
}node;
priority_queue<Node> q;

void bfs(int x,int y){
    node.x=x;node.y=y;
    node.B=0;node.s=0;
    q.push(node);
    b[x][y][0]=1;
    int f=-1;
    while(q.size()){
        
        for(int i=0;i<4;i++){
            int tx=q.top().x+t[i][0];
            int ty=q.top().y+t[i][1];
            if(tx<1||ty<1||tx>n||ty>m) continue;
            int tB=q.top().B;
            int ts=q.top().s+1;
            if(s[tx][ty]==#&&tB<1) continue;
            if(s[tx][ty]==#){
                tB--;
                ts++;
            }
            if(s[tx][ty]==B&&tB<5) tB++;
            if(s[tx][ty]==P) ts--;
            if(s[tx][ty]==T){
                f=ts;
                break;
            }
            if(b[tx][ty][tB]==1) continue;
            b[tx][ty][tB]=1;
            node.x=tx;node.y=ty;
            node.B=tB;node.s=ts;
            q.push(node);
        }
        if(f>-1) break;
        q.pop();
    }
    printf("%d\n",f);
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)&&n+m){
        for(i=1;i<=n;i++){
            scanf(" %s",s[i]+1);
        }
        while(q.size()){
            q.pop();
        }
        memset(b,0,sizeof(b));
        int f=0;
        for(i=1;i<=n;i++){
            for(j=1;j<=m;j++){
                if(s[i][j]==S){
                    bfs(i,j);
                    f=1;
                    break;
                }
            }
            if(f==1) break;
        }
    }
    return 0;
}

 

ACM-ICPC2018北京网络赛 Saving Tang Monk II(bfs+优先队列)

标签:c++   oom   names   imp   cost   com   ons   saving   nod   

原文地址:https://www.cnblogs.com/yzm10/p/9690870.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!