码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1002 A+B for Polynomials

时间:2018-09-23 15:05:22      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:return   scripts   res   lines   base   pre   lin   his   tput   

https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000

 

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码:

#include <bits/stdc++.h>
using namespace std;

double a[1010], b[1010];
int A, B;
double sum[1010];

int main() {
    scanf("%d", &A);
    for(int i = 1; i <= A; i ++) {
        int x;
        scanf("%d", &x);
        scanf("%lf", &a[x]);
    }
    scanf("%d", &B);
    for(int i = 1; i <= B; i ++) {
        int y;
        scanf("%d", &y);
        scanf("%lf", &b[y]);
    }

    int cnt = 0;
    for(int i = 0; i <= 1000; i ++) {
        if(a[i] && b[i])
            sum[i] = a[i] + b[i];
        else if(a[i])
            sum[i] = a[i];
        else if(b[i])
            sum[i] = b[i];
    }
    for(int i = 0; i <= 1000; i ++) {
        if(sum[i])
            cnt ++;
    }
    printf("%d", cnt);
    for(int i = 1000; i >= 0; i --) {
        if(sum[i])
            printf(" %d %.1lf", i, sum[i]);
    }
    printf("\n");
    return 0;
}

  

PAT 甲级 1002 A+B for Polynomials

标签:return   scripts   res   lines   base   pre   lin   his   tput   

原文地址:https://www.cnblogs.com/zlrrrr/p/9692447.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!