码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1009 FatMouse' Trade

时间:2018-09-23 15:06:04      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:clu   +=   work   i++   inpu   roo   val   Requires   bottom   

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 95182    Accepted Submission(s): 33160


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

 

Sample Output
13.333
31.500
 
#include<stdio.h>
#define max 10000
int J[max],F[max];
double  value[max];
int main()
{
    int n,m;
    while(scanf("%d%d",&m,&n))
    {
        if(n==-1&&m==-1) break;
        double ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",J+i,F+i);
            value[i]=1.0*J[i]/F[i];
        }
        for(int i=0;i<n-1;i++)
           for(int j=i+1;j<n;j++)
               if(value[i]<value[j])
               {
                   int t;
                t=J[i];J[i]=J[j];J[j]=t;
                
                t=F[i];F[i]=F[j];F[j]=t;
                
                double t1;
                
                t1=value[i];value[i]=value[j];value[j]=t1;
               } 
        int i=0;
        while(m>0&&i<n)//注意,这里i<n不能掉,因为M很可能大于需求量
        {
            if(m-F[i]>=0)
               ans+=J[i];
            else
               ans+=1.0*m/F[i]*J[i];
            m-=F[i++];
        }
        printf("%.3lf\n",ans);
    }
    return 0;
} 

 

HDU 1009 FatMouse' Trade

标签:clu   +=   work   i++   inpu   roo   val   Requires   bottom   

原文地址:https://www.cnblogs.com/shenyuling/p/9692469.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!