标签:== ems shape panel prepare while cti bottom sts
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25661 Accepted Submission(s):
10401
Problem Description
There is a pile of n wooden sticks. The length and
weight of each stick are known in advance. The sticks are to be processed by a
woodworking machine in one by one fashion. It needs some time, called setup
time, for the machine to prepare processing a stick. The setup times are
associated with cleaning operations and changing tools and shapes in the
machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right
after processing a stick of length l and weight w , the machine will need no
setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘.
Otherwise, it will need 1 minute for setup.
You are to find the minimum
setup time to process a given pile of n wooden sticks. For example, if you have
five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and
(1,4), then the minimum setup time should be 2 minutes since there is a sequence
of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test
cases (T) is given in the first line of the input file. Each test case consists
of two lines: The first line has an integer n , 1<=n<=5000, that
represents the number of wooden sticks in the test case, and the second line
contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at
most 10000 , where li and wi are the length and weight of the i th wooden stick,
respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in
minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
思路:1 .先按长度从小到大排序(如果长度相同,在比较weight)
2. 长度搞好了以后,现在只需看重量weight了,所以从前到后遍历数组,找出所有的weight递增序列,序列总数即所耗时间time,具体看代码,已AC
#include<stdio.h>
#include<string.h>
typedef struct
{
int l;
int w;
} Stick;
Stick stick[5000];
bool flag[5000];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,i,j;
memset(flag,false,sizeof(bool)*5000);
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&stick[i].l,&stick[i].w);
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
if(stick[i].l>stick[j].l||(stick[i].l==stick[j].l&&stick[i].w>stick[j].w))
{
Stick temp=stick[i];
stick[i]=stick[j];
stick[j]=temp;
}
int time=0;
for(i=0;i<n;i++)//找序列 ,由于上面的已经将长度排好序列,现在只要比较宽度就OK了 ,就能找出一个满足条件的子序列
{
if(flag[i]) continue;//stick[i]已经用过了
int w=stick[i].w;//子序列开头 第一个元素的重量
for(j=i+1;j<n;j++)//分别与其他元素比较
{
if(!flag[j]&&w<=stick[j].w)//符合条件,标记一下,防止找别的子序列时重复
{
flag[j]=true;
w=stick[j].w;
}
}
time++;//找到一个只要1分钟序列,
}
printf("%d\n",time);
}
return 0;
}
View Code
HDU 1051 Wooden Sticks
标签:== ems shape panel prepare while cti bottom sts
原文地址:https://www.cnblogs.com/shenyuling/p/9695453.html