码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1009 FatMouse' Trade

时间:2018-09-25 10:45:57      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:output   ott   bsp   hdu   multi   single   name   c++   spec   

http://acm.hdu.edu.cn/showproblem.php?pid=1009

 

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500
 
题解:贪心 从 $J[i] / F[i]$ 最大的开始选
时间复杂度:$O(N * logN)$
代码:
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int N, M;

struct Node{
    double j;
    double f;
    double pri;
}node[maxn];

bool cmp(const Node& a, const Node& b) {
    return a.pri > b.pri;
}

int main() {
    while(~scanf("%d%d", &M, &N)) {
        if(N == -1 && M == -1) break;
        for(int i = 1; i <= N; i ++) {
            scanf("%lf%lf", &node[i].j, &node[i].f);
            node[i].pri = node[i].j / node[i].f;
        }

        double num = 0.0;
        sort(node + 1, node + 1 + N, cmp);
        for(int i = 1; i <= N; i ++) {
            if(M >= node[i].f) {
                num += node[i].j;
                M -= node[i].f;
            }
            else {
                num += M * node[i].j / node[i].f;
                break;
            }
        }
        printf("%.3lf\n", num);
    }
    return 0;
}

  

HDU 1009 FatMouse' Trade

标签:output   ott   bsp   hdu   multi   single   name   c++   spec   

原文地址:https://www.cnblogs.com/zlrrrr/p/9698243.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!