码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1338 Game Prediction

时间:2018-09-25 12:40:40      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:max   nbsp   red   several   term   pid   int   bre   OLE   

http://acm.hdu.edu.cn/showproblem.php?pid=1338

 

Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
 
Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.
 
Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
 
Sample Input
2 5
1 7 2 10 9
 
6 11
62 63 54 66 65 61 57 56 50 53 48
 
0 0
 
Sample Output
Case 1: 2
Case 2: 4
 
题解:贪心 排序
代码:
#include <bits/stdc++.h>
using namespace std;

int N, M;
int num[55];

int main() {
    int Case = 0;
    while(~scanf("%d%d", &N, &M)) {
        Case ++;
        if(!N && !M) break;
        for(int i = 1; i <= M; i ++) {
            scanf("%d", &num[i]);
        }

        int maxx = N * M;
        int cnt = 0;
        sort(num + 1, num + 1 + M);
        for(int i = M; i >= 1; i --) {
            if(num[i] >= maxx) {
                cnt ++;
                maxx --;
            }
            else  maxx -= 2;
        }
        printf("Case %d: %d\n", Case, cnt);
    }
    return 0;
}

  

HDU 1338 Game Prediction

标签:max   nbsp   red   several   term   pid   int   bre   OLE   

原文地址:https://www.cnblogs.com/zlrrrr/p/9698782.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!