码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1052 Tian Ji -- The Horse Racing

时间:2018-09-25 14:07:50      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:fast   opened   hid   data   sse   速度   scan   more   res   

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36559    Accepted Submission(s): 11026


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

技术分享图片

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

 

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
 

 

Sample Output
200
0
0
 
思路:首先这题目就是  田忌赛马,
核心思想:用慢马去消耗King的快马。
代码如下:
技术分享图片
#include<stdio.h>
void sort(int a[],int n)
{
    int i,j;
    for(i=0;i<n;i++)
        for(j=i+1;j<n;j++)
            if(a[i]>a[j])
            {
                int temp=a[i];
                a[i]=a[j];
                a[j]=temp;
            }
}
int main()
{
    int n,tian[1000],king[1000];
    int tian_fast,tian_slow,king_fast,king_slow;
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)
            scanf("%d",tian+i);
        sort(tian,n);
        for(int i=0;i<n;i++)
            scanf("%d",king+i);
        sort(king,n);
        tian_fast=king_fast=n-1;
        tian_slow=king_slow=0;
        int ans=0;
        while(n--)
        {
            if(tian[tian_slow]>king[king_slow])
            {
                ans++;
                tian_slow++;
                king_slow++;
            }
            else if(tian[tian_slow]<king[king_slow])//田鸡用慢马消耗King的快马 
            {
                ans--;
                tian_slow++;
                king_fast--;
            }
            else                                  //慢马的速度相同, 
            {
                if(tian[tian_fast]>king[king_fast])//田鸡的快马战胜King的快马 
                {
                    ans++;
                    tian_fast--;
                    king_fast--;
                }
                else if(tian[tian_slow]<king[king_fast])//田鸡的快马打不过,阴险的用慢马去消耗King快马, 
                {
                    ans--;
                    king_fast--;
                    tian_slow++;
                }
                //这里少了一种,田鸡慢马的速速==King快马的速度,的情况,不过是故意用于 处理相等的情况 
            }
        }
        printf("%d\n",200*ans);
     } 
     return 0;
}
View Code

 

HDU 1052 Tian Ji -- The Horse Racing

标签:fast   opened   hid   data   sse   速度   scan   more   res   

原文地址:https://www.cnblogs.com/shenyuling/p/9699038.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!