码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1004 Let the Balloon Rise

时间:2018-09-26 21:39:27      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:targe   highlight   printf   mina   solution   sample   char   lin   over   

http://acm.hdu.edu.cn/showproblem.php?pid=1004

 

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
Sample Output
red
pink
 
代码:
#include <bits/stdc++.h>
using namespace std;

char color[1010][20];
int N;
map<string, int> mp;

int main() {
    while(~scanf("%d", &N)) {
        if(!N) break;
        mp.clear();
        memset(color, 0, sizeof(color));
        for(int i = 1; i <= N; i ++) {
            scanf("%s", color[i]);
            mp[color[i]] ++;
        }

        int maxx = 0, temp = 0;
        for(int i = 1; i <= N; i ++) {
            if(mp[color[i]] > maxx) {
                temp = i;
                maxx = mp[color[i]];
            }
        }

        printf("%s\n", color[temp]);
    }
    return 0;
}

  

HDU 1004 Let the Balloon Rise

标签:targe   highlight   printf   mina   solution   sample   char   lin   over   

原文地址:https://www.cnblogs.com/zlrrrr/p/9709659.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!