码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5112 A Curious Matt

时间:2018-09-27 00:02:08      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:return   help   ott   highlight   may   test   acm   wan   with   

                              A Curious Matt

                             Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
                              Total Submission(s): 3369    Accepted Submission(s): 1876


Problem Description
There is a curious man called Matt.

One day, Matt‘s best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.
 

 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

 

Sample Input
2 3 2 2 1 1 3 4 3 0 3 1 5 2 0
 

 

Sample Output
Case #1: 2.00 Case #2: 5.00
Hint
In the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.
 

 

Source
Recommend
liuyiding
参考代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
struct node
{
    int t, x;
}a[maxn];

bool cmp(node a, node b)
{
    return a.t < b.t;
}

int main()
{
    int t;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++)
    {
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%d%d", &a[i].t, &a[i].x);
        sort(a, a + n, cmp);
        double ans = 0;
        for(int i = 1; i < n; i++)
        {
            double cur = (a[i].x - a[i - 1].x) * 1.0 / (a[i].t - a[i - 1].t);
            cur = fabs(cur);
            ans = max(ans, cur);
        }
        printf("Case #%d: %.2f\n", k, ans);
    }
    return 0;
}

  

HDU 5112 A Curious Matt

标签:return   help   ott   highlight   may   test   acm   wan   with   

原文地址:https://www.cnblogs.com/songorz/p/9710540.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!