码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3294(经典后缀数组模板)

时间:2014-10-09 15:36:18      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   strong   

Life Forms
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9820   Accepted: 2708

Description

You may have wondered why most extraterrestrial life forms resemble humans, differing by superficial traits such as height, colour, wrinkles, ears, eyebrows and the like. A few bear no human resemblance; these typically have geometric or amorphous shapes like cubes, oil slicks or clouds of dust.

The answer is given in the 146th episode of Star Trek - The Next Generation, titled The Chase. It turns out that in the vast majority of the quadrant‘s life forms ended up with a large fragment of common DNA.

Given the DNA sequences of several life forms represented as strings of letters, you are to find the longest substring that is shared by more than half of them.

Input

Standard input contains several test cases. Each test case begins with 1 ≤ n ≤ 100, the number of life forms. n lines follow; each contains a string of lower case letters representing the DNA sequence of a life form. Each DNA sequence contains at least one and not more than 1000 letters. A line containing 0 follows the last test case.

Output

For each test case, output the longest string or strings shared by more than half of the life forms. If there are many, output all of them in alphabetical order. If there is no solution with at least one letter, output "?". Leave an empty line between test cases.

Sample Input

3
abcdefg
bcdefgh
cdefghi
3
xxx
yyy
zzz
0

Sample Output

bcdefg
cdefgh

?

Source

Waterloo Local Contest, 2006.9.30

AC代码:

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int Max = 200010;
int  num[Max];
int sa[Max], rank[Max], height[Max];
int wa[Max], wb[Max], wv[Max], wd[Max];
int pos[105];
int ans[105];
int cmp(int *r, int a, int b, int l){
    return r[a] == r[b] && r[a+l] == r[b+l];
}
void da(int *r, int n, int m){          //  倍增算法 r为待匹配数组  n为总长度 m为字符范围
    int i, j, p, *x = wa, *y = wb, *t;
    for(i = 0; i < m; i ++) wd[i] = 0;
    for(i = 0; i < n; i ++) wd[x[i]=r[i]] ++;
    for(i = 1; i < m; i ++) wd[i] += wd[i-1];
    for(i = n-1; i >= 0; i --) sa[-- wd[x[i]]] = i;
    for(j = 1, p = 1; p < n; j *= 2, m = p){
        for(p = 0, i = n-j; i < n; i ++) y[p ++] = i;
        for(i = 0; i < n; i ++) if(sa[i] >= j) y[p ++] = sa[i] - j;
        for(i = 0; i < n; i ++) wv[i] = x[y[i]];
        for(i = 0; i < m; i ++) wd[i] = 0;
        for(i = 0; i < n; i ++) wd[wv[i]] ++;
        for(i = 1; i < m; i ++) wd[i] += wd[i-1];
        for(i = n-1; i >= 0; i --) sa[-- wd[wv[i]]] = y[i];
        for(t = x, x = y, y = t, p = 1, x[sa[0]] = 0, i = 1; i < n; i ++){
            x[sa[i]] = cmp(y, sa[i-1], sa[i], j) ? p - 1: p ++;
        }
    }
}
void calHeight(int *r, int n){           //  求height数组。
    int i, j, k = 0;
    for(i = 1; i <= n; i ++) rank[sa[i]] = i;
    for(i = 0; i < n; height[rank[i ++]] = k){
        for(k ? k -- : 0, j = sa[rank[i]-1]; r[i+k] == r[j+k]; k ++);
    }
}
int judge(int mid,int mx,int T){
    int sum,t;
    int vis[105];
    sum=t=0; memset(vis,0,sizeof(vis));
    for(int i=1;i<=mx;i++){
        if(height[i]>=mid){
            for(int j=1;j<=T;j++){
                if(sa[i]>pos[j-1] && sa[i]<pos[j]){
                    if(!vis[j]){
                        sum++;
                        vis[j]=1;
                    }
                }
                if(sa[i-1]>pos[j-1] && sa[i-1]<pos[j]){
                    if(!vis[j]){
                        sum++;
                        vis[j]=1;
                    }
                }
            }
        }
        else{
            if(sum>T/2)
                ans[++t]=sa[i-1];
            sum=0;
            memset(vis,0,sizeof(vis));
        }
    }
    if(sum>T/2)
        ans[++t]=sa[mx];
    if(t){
        ans[0]=t;
        return 1;
    }
    return 0;
}
int main(){
    int T;
    int sign=0;
    while(scanf("%d",&T)!=EOF){
        if(T==0)
            break;
        int num[100010];
        int len=0; ans[0]=0;
        for(int i=1;i<=T;i++){
            char str[1005]="\0";
            scanf("%s",str);
            int ls=strlen(str);
            for(int j=0;j<ls;j++)
                num[len++]=str[j]-'a'+101;
            pos[i]=len;
            num[len++]=i;
        }
        num[len]=0;
        da(num,len+1,150);
        calHeight(num,len);
        int L,R;
        L=1; R=len;
        while(L<=R){
            int mid=L+R>>1;
            if(judge(mid,len,T))
                L=mid+1;
            else
                R=mid-1;
        }
        if(sign++)
            printf("\n");
        if(L-1==0)
            printf("?\n");
        else{
            for(int i=1;i<=ans[0];i++){
                for(int j=ans[i];j<ans[i]+L-1;j++){
                    printf("%c",num[j]+'a'-101);
                }
                printf("\n");
            }
        }
    }
    return 0;
}


poj 3294(经典后缀数组模板)

标签:des   style   http   color   io   os   ar   for   strong   

原文地址:http://blog.csdn.net/my_acm/article/details/39904371

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!