码迷,mamicode.com
首页 > 其他好文 > 详细

并查集 HDU 2120

时间:2014-10-09 16:12:48      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:并查集

其实就是判断新加的点是否在同一个集合里面bubuko.com,布布扣

代码虐我千百遍,我待代码入初恋bubuko.com,布布扣

Ice_cream‘s world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 583    Accepted Submission(s): 333


Problem Description
ice_cream‘s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
3
 
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <queue>
#include <algorithm>
#include <iostream>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 1000 + 10
#define MAXN1 10000 + 10
int father[MAXN];
int a[MAXN1];
int b[MAXN1];

int find(int x){
    if(x != father[x]){
        father[x] = find(father[x]);
    }

    return father[x];
}

int main(){
    int n,m;
    int i;

    while(~scanf("%d%d",&n,&m)){
        for(i=0;i<MAXN;i++){
            father[i] = i;
        }
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(i=0;i<m;i++){
            scanf("%d%d",&a[i],&b[i]);
        }
        int sum = 0;
        for(i=0;i<m;i++){
            int f1 = find(a[i]);
            int f2 = find(b[i]);
            if(f1 != f2){
                if(f1 < f2){
                    father[f2] = f1;
                }
                else{
                    father[f1] = f2;
                }
            }
            else{
                sum++;
            }
        }
        printf("%d\n",sum);
    }

    return 0;
}


并查集 HDU 2120

标签:并查集

原文地址:http://blog.csdn.net/zcr_7/article/details/39896853

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!