标签:acm 动态规划
Fast Food
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2173 Accepted Submission(s): 930
Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed
ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.
To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company‘s headquarter,
which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.
The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as
![bubuko.com,布布扣](http://img.blog.csdn.net/20141009153620671?watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvc3JfMTk5MzA4Mjk=/font/5a6L5L2T/fontsize/400/fill/I0JBQkFCMA==/dissolve/70/gravity/Center)
must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing
one integer each, giving the positions di of the restaurants, ordered increasingly.
The input file will end with a case starting with n = k = 0. This case should not be processed.
Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.
Output a blank line after each test case.
Sample Input
Sample Output
Chain 1
Total distance sum = 8
Source
解题思路:
题意为 一条路上有 n个商店,每个商店有一个x坐标位置,有k个仓库,要把k个仓库安放在n个位置中的k个上面,每个商店都向最近的仓库来获得补给,求怎么安放这k个仓库,使得每个商店到对应仓库的距离只和加起来最小,输出最小值。
解决本题要意识到两点:
1. 如果要在第i个位置和第j个位置之间安放仓库,那么要把它安放在 (i+j)/2 个位置上,(i+j)/2为整数, 才能保证从i到j个商店到仓库之间的距离之和最短。
2.如果按照题意把k个仓库安放在n个位置上,使得距离和最短,这样求得了最小值, 那么一定符合题意:每个商店都向最近的仓库来获得补给,因为如果不是向最近的,距离和肯定不是最短
用dp[i][j] 代表 前j个商店,有i个仓库
那么状态转移方程为:
dp [ i ] [ j ] = min ( dp [ i ] [ j ] , dp [ i-1 ] [ k] + cost [ k+1 ] [ j ] ) i-1<=k<=j-1
dp[i][j] 要从前一个状态推出来,及前k个商店有i-1个仓库,k是不确定的,但可以确定它的范围,最小是i-1 (一个商店位置上放一个仓库),最大是j-1 ( 把第i个仓库放在第j个位置上) , cost [ i ] [ j ]为在i ,j之间放一个仓库的最小距离和,即前面提到的第1点。
代码:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cmath>
#include <string.h>
using namespace std;
int n,k;
int dp[32][210];//dp[i][j]前j个商店有i个仓库
int dis[210];
const int inf=0x3f3f3f3f;
int cost(int i,int j)
{
int ans=0;
int mid=dis[(i+j)/2];
for(int k=i;k<=j;k++)
ans+=abs(dis[k]-mid);
return ans;
}
int main()
{
int c=1;
while(scanf("%d%d",&n,&k)!=EOF)
{
if(!n||!k)
break;
for(int i=1;i<=n;i++)
scanf("%d",&dis[i]);
memset(dp,inf,sizeof(dp));
for(int i=1;i<=n;i++)
dp[1][i]=cost(1,i);
for(int i=2;i<=k;i++)//第i个仓库
for(int j=1;j<=n;j++)//前j个商店
{
for(int k=i-1;k<=j-1;k++)
dp[i][j]=min(dp[i][j],dp[i-1][k]+cost(k+1,j));
}
printf("Chain %d\n",c++);
printf("Total distance sum = %d\n",dp[k][n]);
printf("\n");
}
return 0;
}
[ACM] HDU 1227 Fast Food (经典Dp)
标签:acm 动态规划
原文地址:http://blog.csdn.net/sr_19930829/article/details/39931649