码迷,mamicode.com
首页 > 其他好文 > 详细

1065.输出梯形

时间:2018-10-02 17:41:03      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:输入   pac   ios   ret   问题   i++   mes   names   code   

题目描述:

输入一个高度h,输出一个高为h,上底边为h的梯形。

输入:

一个整数h(1<=h<=1000)。

输出:

h所对应的梯形。

样例输入:
4
样例输出:
      ****
    ******
  ********
**********
提示:

梯形每行都是右对齐的,sample中是界面显示问题

 

#include<iostream>
using namespace std;

int main()
{
    int h;
    cin>>h;
    int max=3*h-2;
    for(int i=0;i<h;i++)
    {
        for(int j=0;j<2*h-2*i-2;j++)
        {
            cout<<" ";
        }
        for(int m=0;m<h+2*i;m++)
        {
            cout<<"*";
        }
        cout<<endl;
    }
    return 0;
}

 

1065.输出梯形

标签:输入   pac   ios   ret   问题   i++   mes   names   code   

原文地址:https://www.cnblogs.com/bernieloveslife/p/9736430.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!