码迷,mamicode.com
首页 > 其他好文 > 详细

1039.zero-complexity transposition

时间:2018-10-02 17:43:54      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:each   stream   pre   The   题目   enc   namespace   order   pac   

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3

 

#include<iostream>
using namespace std;

int main(){
    int n,i;
    long long a[10001];
    while(cin>>n){
    bool first=true;
    for(i=0;i<n;i++)
    {
        cin>>a[i];
    }
    for(i=n-1;i>=0;i--){
        if(first){
            first=false;
            cout<<a[i];
        }
        else cout<<" "<<a[i];
    }
    cout<<endl;
}
     return 0;
}

 

1039.zero-complexity transposition

标签:each   stream   pre   The   题目   enc   namespace   order   pac   

原文地址:https://www.cnblogs.com/bernieloveslife/p/9736517.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!