码迷,mamicode.com
首页 > 其他好文 > 详细

1041.simple sorting

时间:2018-10-02 18:04:59      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:NPU   输入   else   next   ber   element   anti   tin   numbers   

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.
输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.
输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.
样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8

 

#include<iostream>
#include<algorithm>
using namespace std;

int a[1001],b[1001];
int n;

int main(){
    int i;
    while(cin>>n){
        for(i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n);
        int num=0;
        b[0]=a[0];
        for(i=1;i<n;i++)
        {
            if(a[i]!=a[i-1]) b[++num]=a[i];
        }
        bool first=true;
        for(i=0;i<=num;i++){
            if(first) {
                first=false;
                cout<<b[i];
            }
            else cout<<" "<<b[i];
        }
        cout<<endl;
    }
    return 0;
}

 

1041.simple sorting

标签:NPU   输入   else   next   ber   element   anti   tin   numbers   

原文地址:https://www.cnblogs.com/bernieloveslife/p/9736523.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!