码迷,mamicode.com
首页 > 其他好文 > 详细

HDU(1005)Number Sequence

时间:2018-10-03 00:33:39      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:define   hdu   sse   tip   problem   output   递归   mem   ros   

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43278    Accepted Submission(s): 9449

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
 
Sample Output
2 5
//第一版,直接暴力递归,超时
#include<iostream>
using namespace std;
long long int fac(int A, int B, int n)
{
    if (n == 1 || n == 2)
        return 1;
    else
        return (A * fac(A,B,n - 1) + B * fac(A,B,n - 2)) % 7;
}
int main()
{
    int A, B, n;
    while (cin >> A >> B >> n&&A != 0 && B != 0 && n != 0)
    {
        cout << fac(A, B, n % 48) << endl;
    }
    return 0;
}

 

HDU(1005)Number Sequence

标签:define   hdu   sse   tip   problem   output   递归   mem   ros   

原文地址:https://www.cnblogs.com/gcter/p/9738661.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!