码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2425-Hiking Trip(BFS+优先队列)

时间:2014-10-09 23:47:28      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   io   os   ar   java   for   strong   

Hiking Trip

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1303    Accepted Submission(s): 576


Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You‘ve obtained the area Green‘s in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green‘s current position and his destination, please determine the best path for him. 
 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, VP, VS, VT (1 <= VP <= 100, 1 <= VS <= 100, 1 <= VT <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, SR, SC, TR, TC, (0 <= SR < R, 0 <= SC < C, 0 <= TR < R, 0 <= TC < C), representing your current position and your destination. It is guaranteed that Green‘s current position is reachable – that is to say, it won‘t be a ‘@‘ square.
There is a blank line after each test case. Input ends with End-of-File.
 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

Sample Input
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

Sample Output
Case 1: 14 Case 2: 8 Case 3: -1
前几年的区域赛签到题~ 一开始看了一道过的最多的居然是道网络流。。sad 果断扔了看这道搜索。
题意:给出起点和终点 求最短到达时间,图中有4种点,有墙,树,路,石头,除了石头不能走,其他的三种都可以走,且走每一种点花费的时间均已给出。优先队列+BFS水过。
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
struct node
{
	int x,y,step;
	bool operator <(const node &c)const{
	   return c.step<step;
	}
};
char ma[22][22];
int sx,sy,ex,ey,m,n,vp,vs,vt;
bool vis[22][22];
int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
void bfs()
{
   memset(vis,0,sizeof(vis));
   priority_queue <node> Q;
   node now,next;
   now.x=sx;now.y=sy;now.step=0;
   vis[now.x][now.y]=1;
   Q.push(now);
   while(!Q.empty())
   {
   	  now=Q.top();Q.pop();
   	  if(now.x==ex&&now.y==ey)
	  {
	  	printf("%d\n",now.step);
	  	return ;
	  }
	  for(int i=0;i<4;i++)
	  {
	  	next.x=now.x+dir[i][0];
	  	next.y=now.y+dir[i][1];
	  	if(next.x>=0&&next.x<m&&next.y>=0&&next.y<n&&!vis[next.x][next.y]&&ma[next.x][next.y]!='@')
		{
			if(ma[next.x][next.y]=='T')
			{
				next.step=now.step+vt;
				vis[next.x][next.y]=1;
				Q.push(next);
			}
			else if(ma[next.x][next.y]=='.')
			{
				next.step=now.step+vs;
				vis[next.x][next.y]=1;
				Q.push(next);
			}
			else if(ma[next.x][next.y]=='#')
			{
				next.step=now.step+vp;
				vis[next.x][next.y]=1;
				Q.push(next);
			}
		}
	  }
   }
   printf("-1\n");
}
int main()
{
	int cas=1;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		scanf("%d %d %d",&vp,&vs,&vt);
		for(int i=0;i<m;i++)
			scanf("%s",ma[i]);
		scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
		printf("Case %d: ",cas++);
		bfs();
	}
	return 0;
}


HDU 2425-Hiking Trip(BFS+优先队列)

标签:des   style   color   io   os   ar   java   for   strong   

原文地址:http://blog.csdn.net/qq_16255321/article/details/39938149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!