码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1782 Run Length Encoding

时间:2018-10-06 13:21:16      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:orm   more   ons   names   letters   pass   amp   rem   aaaaa   

题目链接

Run Length Encoding
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5006   Accepted: 1560

Description

Your task is to write a program that performs a simple form of run-length encoding, as described by the rules below. 

Any sequence of between 2 to 9 identical characters is encoded by two characters. The first character is the length of the sequence, represented by one of the characters 2 through 9. The second character is the value of the repeated character. A sequence of more than 9 identical characters is dealt with by first encoding 9 characters, then the remaining ones. 

Any sequence of characters that does not contain consecutive repetitions of any characters is represented by a 1 character followed by the sequence of characters, terminated with another 1. If a 1 appears as part of the sequence, it is escaped with a 1, thus two 1 characters are output. 

Input

The input consists of letters (both upper- and lower-case), digits, spaces, and punctuation. Every line is terminated with a newline character and no other characters appear in the input.

Output

Each line in the input is encoded separately as described above. The newline at the end of each line is not encoded, but is passed directly to the output.

Sample Input

AAAAAABCCCC
12344

Sample Output

6A1B14C
11123124

题意:找出连续相同的字符有多少个
   (1)2<=连续字符长度<=9 输出个数+字符;>9把9个先输出,后面的截断再判断
   (2)没有相同字符的子序,在第一个和最后一个字符前面输出1,如果字符是1,就用1转意,所以1个1就是11;

AC代码:

#include<cstring>
#include<cstdio>
using namespace std;
const int N=1010;
char s[N];
int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    while(gets(s)!=NULL){
        int len=strlen(s);
        int i=0,j;
        while(i<len){
                
            int k=1;
            while(s[i]==s[i+1]&&i<len){
                k++;
                i++;
                if(k>=9) break;
            }
            if(k>1) {
                printf("%d%c",k,s[i-1]);
                i++;
            }
            if(i>=len) break;
            if(s[i]!=s[i+1]){
                printf("1");
                while(s[i]!=s[i+1]&&i<len){
                    if(s[i]==1) printf("1");
                    printf("%c",s[i]);
                    i++;
                }
                printf("1");
            }
        }
        printf("\n");
    }
    return 0;
}

 

poj 1782 Run Length Encoding

标签:orm   more   ons   names   letters   pass   amp   rem   aaaaa   

原文地址:https://www.cnblogs.com/kun-/p/9746996.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!