码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2030 汉字统计

时间:2018-10-06 20:34:55      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:整数   namespace   通话   hint   max   acs   key   show   测试   

Problem Description
统计给定文本文件中汉字的个数。
 

 

Input
输入文件首先包含一个整数n,表示测试实例的个数,然后是n段文本。
 

 

Output
对于每一段文本,输出其中的汉字的个数,每个测试实例的输出占一行。

[Hint:]从汉字机内码的特点考虑~

 

 

Sample Input
2 WaHaHa! WaHaHa! 今年过节不说话要说只说普通话WaHaHa! WaHaHa! 马上就要期末考试了Are you ready?
 

 

Sample Output
14 9
 

 

Author
lcy
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2031 2032 2026 2027 2024 
 
一个汉字占两个字节,也就是两个char,且acsii码为负。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 0x3f3f3f3f
#define MAX 100000
using namespace std;

int n;
char s[10000];
int main() {
    scanf("%d\n",&n);
    while(n --) {
        gets(s);
        int ans = 0;
        for(int i = 0;s[i];i ++) {
            if(s[i] < 0) ans ++;
        }
        printf("%d\n",ans / 2);
    }
}

 

hdu 2030 汉字统计

标签:整数   namespace   通话   hint   max   acs   key   show   测试   

原文地址:https://www.cnblogs.com/8023spz/p/9748262.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!