码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5514 容斥原理

时间:2018-10-15 21:46:37      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:lin   原理   multiple   res   暴力   i++   应该   href   can   

Frogs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4843    Accepted Submission(s): 1605


Problem Description
There are m stones lying on a circle, and n frogs are jumping over them.
The stones are numbered from 0 to m?1 and the frogs are numbered from 1 to n. The i-th frog can jump over exactly ai stones in a single step, which means from stone j mod m to stone (j+ai) mod m (since all stones lie on a circle).

All frogs start their jump at stone 0, then each of them can jump as many steps as he wants. A frog will occupy a stone when he reach it, and he will keep jumping to occupy as much stones as possible. A stone is still considered ``occupied" after a frog jumped away.
They would like to know which stones can be occupied by at least one of them. Since there may be too many stones, the frogs only want to know the sum of those stones‘ identifiers.
 

 

Input
There are multiple test cases (no more than 20), and the first line contains an integer t,
meaning the total number of test cases.

For each test case, the first line contains two positive integer n and m - the number of frogs and stones respectively (1n10^4 1m10^9).

The second line contains n integers a1,a2,?,an, where ai denotes step length of the i-th frog (1ai10^9).
 

 

Output
For each test case, you should print first the identifier of the test case and then the sum of all occupied stones‘ identifiers.
 

 

Sample Input
3
2 12
9 10
3 60
22 33 66
9 96
81 40 48 32 64 16 96 42 72
 
Sample Output
Case #1: 42
Case #2: 1170
Case #3: 1872
 
Source

 解析  这道题真的非常好,有技巧的容斥。

AC代码

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
#define maxn 10005
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
//每个青蛙,可以跳到gcd(m,a[i])*k的位置
int ppp[maxn];
int num[maxn],vis[maxn];
int main()
{
    int tt;scanf("%d",&tt);
    for(int cas=1;cas<=tt;cas++)
    {
        int n,m;
        int cnt = 0;
        memset(vis,0,sizeof(vis));
        memset(num,0,sizeof(num));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=sqrt(m);i++)//把因子全部筛出来
        {
            if(m%i==0)
            {
                ppp[cnt++]=i;
                if(i*i!=m)
                    ppp[cnt++]=m/i;
            }
        }
        sort(ppp,ppp+cnt);
        for(int i=0;i<n;i++)
        {
            int x;scanf("%d",&x);
            int kk = gcd(x,m);
            for(int j=0;j<cnt;j++)
                if(ppp[j]%kk==0)//说明这个因子的所有,都是可以被跳到的位置
                    vis[j]=1;
        }
        vis[cnt-1]=0;//显然 m是不可能被跳到的
        long long ans = 0;
        for(int i = 0; i < cnt; i++)
        {
            if(vis[i] != num[i])
            {
                int t = (m-1)/ppp[i];
                ans += (long long)t*(t+1)/2 * ppp[i] * (vis[i]-num[i]);
                //容斥一波
                //一开始vis[i] - num[i] = 1的
                //对于每个因数,如果重复计算了,在之后,减去就好了
                t = vis[i] - num[i];
                for(int j = i; j < cnt; j++)
                    if(ppp[j]%ppp[i] == 0)
                        num[j] += t;
            }
        }
        printf("Case #%d: %lld\n",cas,ans);
    }
}

wa的代码,暴力容斥,极限数据是36个gcd 应该直接爆复杂度了,不应该是wa的

#include <bits/stdc++.h>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define all(a) (a).begin(), (a).end()
#define fillchar(a, x) memset(a, x, sizeof(a))
#define huan printf("\n")
#define debug(a,b) cout<<a<<" "<<b<<" "<<endl
#define ffread(a) fastIO::read(a)
using namespace std;
typedef long long ll;
typedef pair<int,int> pii;
const int maxn=1e4+10;
ll gcd(ll a,ll b)
{
    return b?gcd(b,a%b):a;
}
ll sum(ll x,ll n)
{
    ll temp=(n-1)/x;
    return temp*x+(temp*(temp-1)/2)*x;
}
int main()
{
    ll t,n,m;
    int kase=1;
    scanf("%lld",&t);
    while(t--)
    {
        set<ll> s;
        scanf("%lld%lld",&n,&m);
        for(int i=0;i<n;i++)
        {
            ll x;
            scanf("%lld",&x);
            s.insert(gcd(x,m));
        }
        vector<ll> g;
        for(auto it:s)
        {
            int flag=1;
            for(auto itt:s)
                if(it%itt==0&&it!=itt)
                 flag=0;
            if(flag)g.pb(it);
        }
        ll cnt=g.size();
        ll ans=0;
        for(ll i=0; i<(1ll<<cnt); i++)
        {
            ll temp=1,jishu=0;
            for(ll j=0; j<cnt; j++)
            {
                if(i&(1<<j))
                    temp=temp*g[j]/gcd(g[j],temp),jishu++;
            }
            if(jishu==0)
                continue;
            if(jishu%2==1)
                ans+=sum(temp,m);
            else
                ans-=sum(temp,m);
        }
        printf("Case #%d: %lld\n",kase++,ans);
    }
}

 

HDU 5514 容斥原理

标签:lin   原理   multiple   res   暴力   i++   应该   href   can   

原文地址:https://www.cnblogs.com/stranger-/p/9794848.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!