码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5384 Danganronpa

时间:2018-10-16 17:37:03      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:cst   更新   atom   min   namespace   ant   owa   recommend   ota   

Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series‘ name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are n技术分享图片 verbal evidences, and Stilwell has m技术分享图片 "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings A技术分享图片i技术分享图片技术分享图片 , and bullets are some strings B技术分享图片j技术分享图片技术分享图片 . The damage to verbal evidence A技术分享图片i技术分享图片技术分享图片 from the bullet B技术分享图片j技术分享图片技术分享图片 is f(A技术分享图片i技术分享图片,B技术分享图片j技术分享图片)技术分享图片 .
f(A,B)=技术分享图片i=1技术分享图片|A||B|+1技术分享图片[ A[i...i+|B|1]=B ]技术分享图片
In other words, f(A,B)技术分享图片 is equal to the times that string B技术分享图片 appears as a substring in string A技术分享图片 .
For example: f(ababa,ab)=2技术分享图片 , f(ccccc,cc)=4技术分享图片

Stilwell wants to calculate the total damage of each verbal evidence A技术分享图片i技术分享图片技术分享图片 after shooting all m技术分享图片 bullets B技术分享图片j技术分享图片技术分享图片 , in other words is 技术分享图片m技术分享图片j=1技术分享图片f(A技术分享图片i技术分享图片,B技术分享图片j技术分享图片)技术分享图片 .
 

 

Input
The first line of the input contains a single number T技术分享图片 , the number of test cases.
For each test case, the first line contains two integers n技术分享图片 , m技术分享图片 .
Next n技术分享图片 lines, each line contains a string A技术分享图片i技术分享图片技术分享图片 , describing a verbal evidence.
Next m技术分享图片 lines, each line contains a string B技术分享图片j技术分享图片技术分享图片 , describing a bullet.

T10技术分享图片
For each test case, n,m10技术分享图片5技术分享图片技术分享图片 , 1|A技术分享图片i技术分享图片|,|B技术分享图片j技术分享图片|10技术分享图片4技术分享图片技术分享图片 , |A技术分享图片i技术分享图片|10技术分享图片5技术分享图片技术分享图片 , |B技术分享图片j技术分享图片|10技术分享图片5技术分享图片技术分享图片
For all test case, |A技术分享图片i技术分享图片|610技术分享图片5技术分享图片技术分享图片 , |B技术分享图片j技术分享图片|610技术分享图片5技术分享图片技术分享图片 , A技术分享图片i技术分享图片技术分享图片 and B技术分享图片j技术分享图片技术分享图片 consist of only lowercase English letters
 

 

Output
For each test case, output n技术分享图片 lines, each line contains a integer describing the total damage of A技术分享图片i技术分享图片技术分享图片 from all m技术分享图片 bullets, 技术分享图片m技术分享图片j=1技术分享图片f(A技术分享图片i技术分享图片,B技术分享图片j技术分享图片)技术分享图片 .
 

 

Sample Input
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

 

Sample Output
1 1 0 3 7
 

 

Author
SXYZ
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 
给出n个A串和m个B串,对于每个A串,输出里面出现了几次B串,ac自动机对所有B串构建字典树,然后进行匹配查找。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define MAX 100001
using namespace std;

int pos;
int trie[MAX][26],fail[MAX] = {-1},sum[MAX];
char s[100001][10001];
void Insert_Str(char *s) {///字符串插入到字典树中
   int i = -1,r = 0;
   while(s[++ i]) {
       int d = s[i] - a;
       if(!trie[r][d]) {
           trie[r][d] = ++ pos;
       }
       r = trie[r][d];
   }
   sum[r] ++;
}
void Build_Fail() {///通过父结点的Fail更新子结点的Fail
    queue<int> q;
    q.push(0);
    while(!q.empty()) {
        int id = q.front();
        q.pop();
        for(int i = 0;i < 26;i ++) {
            if(trie[id][i]) {///第i个儿子存在
                int temp = fail[id];///temp赋值当前节点的Fail
                while(temp != -1) {
                    if(trie[temp][i]) {
                        fail[trie[id][i]] = trie[temp][i];
                        break;
                    }
                    temp = fail[temp];
                }
                q.push(trie[id][i]);
            }
        }
    }
}
void Ac_automation(int k) {
    int i = -1,r = 0,ans = 0;
    while(s[k][++ i]) {
        int d = s[k][i] - a;
        while(r && !trie[r][d]) r = fail[r];///如果没有匹配的子结点 就找它的Fail看看有没有匹配的子结点
        if(trie[r][d]) r = trie[r][d];
        int temp = r;
        while(temp) {
            ans += sum[temp];
            temp = fail[temp];///找最长后缀
        }
    }
    printf("%d\n",ans);
}
int main() {
    char str[10001];
    int t,n,m;
    scanf("%d",&t);
    while(t --) {
        pos = 0;
        memset(trie,0,sizeof(trie));
        memset(fail + 1,0,sizeof(fail));
        memset(sum,0,sizeof(sum));
        scanf("%d %d",&n,&m);
        for(int i = 0;i < n;i ++) {
            scanf("%s",s[i]);
        }
        for(int i = 0;i < m;i ++) {
            scanf("%s",str);
            Insert_Str(str);
        }
        Build_Fail();
        for(int i = 0;i < n;i ++) {
            Ac_automation(i);
        }
    }
    return 0;
}

 

hdu 5384 Danganronpa

标签:cst   更新   atom   min   namespace   ant   owa   recommend   ota   

原文地址:https://www.cnblogs.com/8023spz/p/9798811.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!