码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2240 Arbitrage

时间:2018-10-16 19:21:50      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:clu   cpp   real   from   desc   ast   enc   ref   contain   

http://poj.org/problem?id=2240

 

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

代码:

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<vector>
#include<map>
using namespace std;

int N, M;
char name[110];
map<string, int> mp;
double maze[1010][1010];

void floyd() {
    for(int k = 1; k <= N; k ++) {
        for(int i = 1; i <= N; i ++) {
            for(int j = 1; j <= N; j ++) {
                if(maze[i][j] < maze[i][k] * maze[k][j])
                    maze[i][j] = maze[i][k] * maze[k][j];
            }
        }
    }
}

int main() {
    int Case = 1;
    char s1[110], s2[110];
    double cost;
    while(~scanf("%d", &N)) {
        if(!N) break;
        memset(maze, 0, sizeof(maze));
        for(int i = 1; i <= N; i ++)
            maze[i][i] = 1;

        for(int i = 1; i <= N; i ++) {
            scanf("%s", name);
            mp[name] = i;
        }
        scanf("%d", &M);
        for(int i = 1; i <= M; i ++) {
            scanf("%s%lf%s", s1, &cost, s2);
            maze[mp[s1]][mp[s2]] = cost;
        }

        floyd();
        printf("Case %d: ", Case ++);

        for(int i = 1; i <= N; i ++) {
            if(maze[i][i] > 1) {
                printf("Yes\n");
                break;
            }
            else if(i == N)
                printf("No\n");
        }
    }
    return 0;
}

  

POJ 2240 Arbitrage

标签:clu   cpp   real   from   desc   ast   enc   ref   contain   

原文地址:https://www.cnblogs.com/zlrrrr/p/9799918.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!